
Interactive Physics Manual 
 Pieces of this manual have been shamelessly pirated from the Interactive Physics User’s 
Manual published by Knowledge Revolution.  This manual is intended to be used solely as a 
guide in Physics Laboratory at Las Positas Community College, and is not meant to be sold for 
profit, other than to cover the cost of reproduction. 
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What is Interactive Physics? 
Interactive Physics is a simulation program that allows for exploration and 
analysis of “physical” situations.  The student may model the physical world on 
any scale, from atomic to astronomical, and even experiment with physical 
situations not found in our universe.   
 
The program opens up to an “infinite” world-space (limited primarily by available 
memory), and using relatively simple paint-and-draw techniques a laboratory may 
be constructed.  The default settings of the program allow for nearly immediate 
manipulation of the “real-life” world of tables, balls, springs and pulleys.  A bit of 
work will allow analysis of the orbit of Jupiter’s moons.  The truly motivated user 
may create an astronomical situation where the force of gravity repels, rather than 
attracts massive bodies. 

  
The Interactive Physics world has two levels: the Physical level and the Interface 
level.  The Physical level is where you will put the Mass Objects; figures drawn to 
represent physical objects such as tables and balls; and Constraints, such as 
springs, joints, and pulleys.  The Interface level allows you to monitor the 
Physical level with meters and controls.   

 
This manual serves as an introduction to the capabilities of the Interactive Physics 
program.  You may want to read through it before using the software, and refer 
back to it as needed.  If you find something missing, there is an excellent Help 
section within the program, and as a last resort your instructor has an official 
manual. 

 
 Have Fun and Good Luck! 
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Mass Objects 
 

Drawing Mass Objects 
Mass objects are geometric shapes that have a number of parameters defining 
their behavior.  In the Interactive Physics simulation program, mass objects are 
created much in the same way as in a draw or paint program.  
 

 Anchoring Mass Objects 
The Anchor tool limits an object’s motion in the environment.  To use: Select 
the Anchor tool then click inside the mass object.  To remove the Anchor, 
repeat this process. 

 
Mass Properties 
Each mass object in the environment behaves according to it’s own set of 
properties.  Mass properties are changed using the Properties utility window.  
Double-clicking on a mass object will bring up said window.   

 
Holding down the shift key allows you to select numerous objects at once.  
Double-clicking on one of the objects (with the shift key held down) will bring up 
a Properties utility window.  The pop-up menu at the top of the utility window is 
labeled mixed selection.  This allows you to change properties for these mass 
objects in one fell swoop (ex.  turn all objects’ material from standard to wood).  
You may then change properties for individual objects simply by selecting the 
desired object from the pop-up menu. 
 
You may change the following properties: 
� Initial Position: x, y, φ 
� Initial Velocity: Vx, Vy, Vφ 
� Material 
� Mass 
� Static Friction 
� Kinetic Friction 
� Elasticity 
� Charge 
� Density 
� Moment of Inertia 

 
Mass Appearance 
You may change the appearance of a mass object by selecting that object, and 
choose Appearance from the Window menu. 
You may change an object’s Pattern or Color.  You may show an object’s Name, 
Center of Mass, or Charge.  You may Track on object’s Center of Mass with a 
series of dots, Connect the dots with a solid line, and/or Track the Outline of the 
object. 
 
 
 
 
 

 ii 
 



Constraints 
 
There are four classes of constraints in Interactive Physics: 
 

Linear Constraints have two endpoints and apply a force along the line 
connecting the two endpoints.  They include Springs, Dampers, Ropes, Rods, 
Separators, Actuators and Pulleys.  
 
 separator spring

damper

 
 

actuator  
 

Forces produced by these constraints act equally and in opposite directions upon 
the mass objects at either endpoint. 
 
To construct a linear constraint: 

� Select the appropriate tool. 
� Position the pointer in an empty area of the screen.  
� Hold down the mouse button to create the first endpoint. 
� Drag the mouse to the desired location of the second endpoint.  
� Release the mouse button to create the second endpoint. 

 
 
Rotational Constraints apply a twisting force (torque) between two objects. 
They include Motors, Gears, Rotational Springs and Rotational Dampers. 

 All except gears include a pin joint. 
 rotational damper motor 

gears 

 
 rotational spring 
 
 
If a rotational constraint is drawn over a single mass object it will attach the mass 
object to the background beneath (behind) it.  If a rotational constraint is drawn 
over two (overlapping) mass objects, it will attach to both objects. 

 
 To draw a rotational constraint: 

� Select the tool or constraint you wish to draw. 
� Position the pointer in over the mass(es) you wish, and click once. 

 
Joints connect two mass objects and constrain their motion relative to one 
another.  This includes Pin Joints, Rigid Joints and Slot Joints. 
Pin Joints allow rotation while forcing points on two different mass objects to 
overlap.  Rigid Joints lock two mass objects together. 
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 To create a Pin or Rigid Joint: 
� Align the mass objects that will be connected by the joint. 
� Select the appropriate tool from the toolbar. 
� Click the mouse to create the joint at the proper location. 

 
In the case that more than two mass objects are overlapped, the joint will connect 
the top two mass objects. 

 
 

Forces and Torques: Forces exert a linear force on a mass object at a single 
point.  Torque exerts a twisting force on a mass object.  Both are attached to the 
top-most mass object lying under the pointer at the time of the click.   
 
To create a Force: 

� Select the Force tool. 
� Move the pointer to the location where the force is to act on the 

mass object. 
� Drag the pointer to create a force object.   

A Force can be edited by grabbing and dragging the arrow, or by using the 
Properties utility window.  To move the force, click anywhere except on its 
endpoint, and drag to a new location. 

  
 To create a Torque: 

� Select the Torque tool. 
� Click on the mass object to which the torque is to be applied. 
� Use the Properties utility window to set the magnitude of the 

torque. 
 
 

The Workspace 
 

Physical Objects and Interface Objects 
The Interactive Physics simulation world has two layers: the Physical layer and 
the Interface, or User, layer.  Physical objects, such as mass objects, points and 
constraints, exist on the Physical layer.  The Interface layer contains user objects, 
such as meters, controls (sliders, text boxes, buttons), and pictures that are not 
attached to a physical object.  The Interface layer is considered the “back” layer, 
and thus it is possible to position a physical object so that it obscures a user 
object. 

 
Viewing Options 
Interactive Physics provides an infinite workspace that is larger than what can be 
displayed on screen at one time.  The area occupied is called the world.  What you 
see on the screen is only a small part of the world, called the view. 
 
You may use the horizontal and vertical scroll bars to change your view to a 
different part of the world. 
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The zoom tools increase or decrease the magnification of the objects in the world. 
 

Workspace Tools and Controls 
 You may display the following tools and controls in your workspace: 

� Toolbar 
� Scroll Bars 
� Coordinates and Grid Lines 
� Tape Player 
� Rulers  
� Help Ribbon 

These are accessed through the Workspace sub-menu of the View pull-down 
menu.  To choose many options at once, choose Workspace… .  A check mark 
next to the option name indicates the option is on. 
 
The Help Ribbon is a band across the top of the workspace.  It displays 
information about the tool or object that is currently under the pointer. 

 
Numbers and Units  
The default of the program is to use the SI/metric system of units.  However, you 
may change to English, astronomical, atomic, or CGS systems by choosing 
Numbers and Units from the View menu.  Changing a system of units will affect 
all constants and formulas being used. 
 
Defining World Parameters  
The Interactive Physics simulation world contains four environment parameters, 
accessed through the World menu: 
� Gravity 
� Air Resistance 
� Electrostatics 
� Force Field 

The default setting for Gravity is “Earth = 9.8 m/s2”.  The default for the other 
three is “None”. 

 Meters 
Measurements may be made of almost any physical property in your simulation.  
Once you have selected a particular object, look at the Measure pull-down menu 
to see what properties are available.  For example, for a mass object you may 
measure position, velocity and acceleration of its center of mass.   
 
All measurements are facilitated through the use of meters.  You may choose 
from digital, graph or bar meters. 

 
To create a meter: 
� Select one mass object, point, or constraint object whose properties you 

wish to measure.  To measure contact or friction force, you must select 
two mass objects before you create a meter. 

� Choose the property you wish to measure from the Measure menu.  A 
meter with a numerical display appears. 
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� To select the display mode (bar, graph, digital) for the meter, click on the 
down arrow button on the top left corner of the meter window. 

� Click in the labeled buttons on the side of the meter to select which 
parameters to display. 

� You can compare the results of multiple simulations by activating the 
Retain Meter Values option in the World menu. 

� You may export retained meter values to another file by choosing Export 
Data from the File menu. 

 
Specifics for Graph Meters: 
� Changing the scale of a displayed graph: 

• Select the meter 
• Choose Properties from the Window menu. 
• Enter Min and Max values for the quantity you wish to scale 

� Changing the color of lines on a graph 
• Select the meter. 
• Choose Appearance from the Window menu. 
• Select the desired color for each parameter by clicking in the color 

pop-up menu. 
Controls 
Controls allow you to adjust simulation parameters before and while a simulation 
is running.  A control may take the form of a slider (default), a text box, or a 
button.   
 
To create a control: 
� Select the object whose properties you want to change. 
� Select the New Control menu item from the Define menu. 
� Choose the desired property. 
� Change the properties of the control by double clicking or selecting the 

control, and choosing Properties from the Window menu. 
� You may change the title or color of a control by choosing Appearance 

from the Window menu. 
� You can specify minimum and maximum values for the slider bars.  

“Number of snaps” indicates how many discrete values are available in the 
range of the slider. 

� A text box allows you to enter a precise numerical input of the property 
value. 

� Using a button, you can quickly select one of the two values specified in 
min and max boxes.  A button can be a toggle switch or a press-and-hold 
button. 
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Menu Buttons 
Creating menu buttons allows you to place a shortcut to common commands 
directly on the workspace. 
 
To create a menu button: 
� On a Macintosh: 

• Choose New Menu Button from the Define menu. 
• Choose a command from an Interactive Physics menu. 

� On Windows: 
• Choose New Menu Button from the Define menu. 
• Choose a command from the list. 
• Click OK. 

 
Vectors 
The following properties can be represented graphically with vectors: 
� Velocity 
� Acceleration 
� Total force 
� Gravitational Force 
� Electrostatic Force 
� Air Force (Air Resistance) 
� Force Field 
� Contact Force 
� Friction Force 

Vectors that designate velocity and acceleration are always drawn pointing out 
from a mass object’s center of mass.  Vectors displaying force quantities can be 
drawn either pointing from or toward a mass object’s center.  Vectors that display 
forces encountered when objects contact one another can be displayed at the point 
of contact or a the mass center of each object. 
 
To display vectors: 
� Select one or more objects whose vectors you want to display graphically. 
� Choose the type of vector to display from the Vectors sub-menu of the 

Define menu.  The vectors will be displayed the next time the simulation 
is run. 

� The length of a vector may be altered by choosing Vector Lengths from 
the Define menu.  Use sliders or enter a number to adjust lengths for 
velocity, force and acceleration vectors. 

� Vector color may be changed by choosing Vector Display from the 
Vectors menu. 

� Choose inward or outward pointing vectors from the Vector Display 
menu. 
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Running Simulations 
 
 To Run a Simulation 
 Click Run in the toolbar or choose Run from the World menu.   
 
 To Stop a Simulation 
 You can stop a simulation in various ways: 

� Click Stop in the tool palette. 
� Click the Stop icon on the tape player controls. 
� Click anywhere in the window if the cursor appears as a stop sign 
� Choose Stop from the World menu. 
� Click on a Stop menu button, if one exists. 
� Automatically stop the simulation using the Pause feature. 
� Macintosh only: Press Command and . (period) from the keyboard. 

  
Using Tape Player Controls 
While playing a simulation, Interactive Physics also records it using a feature 
called the Tape Player.  This allows you to play simulations backward or frame by 
frame, to skip frames of the simulation, and to play the simulation more quickly 
after all calculations have been completed. 
 
To display the Tape Player controls: 
� Choose Workspace from the View menu. 
� Select the Tape Player Controls option 
� Click OK 
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Frame  
Indicator 

Run 
Step Forward Run Backward Step Backward 

  
Stepping Through Frames may be done in two ways: 

� Click on the forward or backward step in the tape player control to move 
one frame at a time. 

� Press + to step forward and – to step backward. 
To select the number of frames to skip with the step controls: 
� Choose Skip Frames from the World menu. 
� Choose one of the numbers from the sub menu. 

To skip frames for faster animation: 
� Choose Skip Frames from the World menu without letting go the mouse 

button. 
� Choose the number of frames you wish to skip from the Skip Frames sub-

menu. 
 
Playing a Simulation Backward 
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After you have run a simulation, you may play it backward by clicking the play 
backward control on the tape player.  If you do not stop the simulation first, it will 
stop by itself when it reaches the first frame.  As the animation runs backward, the 
frame indicator moves to the left while displaying the number of the current frame 
of animation. 

 
Speeding up Playback 
When a simulation is run for the first time, Interactive Physics not only draws the 
animation on the screen, but also calculates the motion.  For complicated 
simulations, this may slow down the animation the first time it is run.  You can 
increase the playback speed by playing the recorded simulation again 
(calculations are stored and need not be recalculated) or by using the Skip feature.  
Skipping increases animation speed by removing frames from the calculation. 
 
Other tips for making your simulation run faster: 
� Use the Fast simulation method, and set the time step to the largest value 

that allows stable simulation and acceptable accuracy. 
� Reduce the number of objects that are in contact.  Make sure to use the Do 

Not Collide command (in the Object menu) with all groups of objects that 
do not need to collide.   

� Set the frictional coefficients of contacting objects to 0.0 if friction is not 
needed in your simulation. 

� Use rigid joints to build complex objects.  Using two pin joints to lock 
objects together introduces extra simulation overhead and redundant 
constraints. 

� Use rods instead of ropes wherever possible. 
� Use rods instead of pinned mass objects wherever possible.  A truss 

constructed of small mass objects connected by rods will simulate more 
quickly than a truss constructed of pinned rectangles. 

� Make your window size smaller.  A smaller window size requires less 
graphics-processing time. 

  
Recording a Simulation 
Recording a simulation requires a great deal of memory.  Interactive Physics 
automatically uses all available memory to store large simulations.  If your 
simulation has used up all available memory, you will see the following dialogue 
box: 
 
 
                                   

 
 
                                          
           RunStop 

! 
The tape player is full. Keep running 
and write over the beginning of the 
tape? 
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If the tape player memory is full, you can continue running your simulation in 
several ways: 
� Close other Interactive Physics documents to make more memory 

available to the tape player. 
� Make more memory available to Interactive Physics. 
� Let the tape player “loop” and continue running the simulation. 
� Increase the time step of the simulation, resulting in more spacing between 

frames.  An increase in space between frames allows you to record the 
simulation for a longer time in the tape player.  When doing this, the 
simulation may have to be run in a more accurate mode. 

Running a Simulation Beyond What can be Recorded 
When the memory allocated for recording a simulation is full, you can either stop 
the simulation or continue the simulation while erasing the initial frames of the 
recording. 
 
Using the Settings of an Existing Simulation for a New One 
You can use the current condition of a simulation as the initial condition for a new 
simulation: 
� Drag the frame indicator to the desired starting point. 
� Choose Start Here from the World menu. 

The current frame becomes frame zero, and the original initial conditions are lost.  
Save your simulation with a new name before setting new initial conditions if you 
wish to re-use the old initial conditions at some later time. 
 
Tracking 
Tracking leaves an image trace of moving objects at adjustable time intervals.  
You can track individual objects or all objects.  Objects can leave visible tracks of 
their outline, center of mass, or vectors so that you can follow the physical action 
throughout a simulation. 
 
To activate tracking: 
� Set-up or load a simulation. 
� Choose Track from the World menu. 
� Select how often you wish to track from the Track sub-menu. 

 
To control which individual components of each object are tracked: 
� Select the object whose individual tracking behavior you want to define. 
� Choose Appearance from the Window menu. 
� Click on the desired tracking options. 

 
If you want to track only one or more objects, after activating Tracking select all 
constraints and mass objects and deselect all tracking options shown in the 
Appearance window.  Then select just the mass objects and constraints you want 
to track and check the tracking options you want enabled for those objects. 
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Running multiple simulations with multiple tracks 
The default behavior for Interactive Physics is to erase tracks whenever 
something that may affect the results of the simulation is modified (such as 
changing a mass object’s property).  Disabling the AutoErase Track item in the 
World menu will allow simulations with multiple overlapping tracks.  Selecting 
Erase Track from the World menu will erase all tracks and refresh all meters 
and other objects on the Interface layer. 
 
Printing Simulations 
You can print a frame of your simulation to any printer supported by your 
Macintosh or Windows system using the Print command. 
 
Macintosh Printing 
Selecting page size and orientation: 
Before choosing Print, you can specify options for printing, such as the size of 
the paper and the orientation of objects on the printed pages.   

To specify print options: 
� Create or open up a simulation. 
� Choose Page Setup from the File menu. 

The information you see in the Page Setup dialogue box varies depending on the 
system and printer you are using. 
Printing 
After you have positioned your simulation within the window at the desired Zoom 
and location, you are ready to print the simulation. 

To print: 
� Open a simulation. 
� Choose Print from the File menu. 
� Click OK. 

 
Windows Printing 
After you have positioned your simulation within the window at the desired Zoom 
and location, you are ready to print. 

To print: 
� Create or open a simulation. 
� Choose Print from the File menu. 
� Select any other Print options by clicking the Setup… button. 
� Click OK. 
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Useful Tips and Shortcuts 
  
 Using Modifier Keys 
 

Macintosh 
 
 Using the Shift Key  

To select more than one item, hold down the Shift key while clicking the items 
you want.  Clicking on an already selected object while holding down the Shift 
key deselects the object. 

 
 Using the Option Key 

To maintain the rest length of a constraint while resizing, hold down the Option 
key. 

 
 Using the Command Key 

To maintain current connections of constraints and mass objects when dragging, 
hold down the Command key. 

 
 Using the Tab Key 

Use the Tab key to select the first value in a utility window without having to 
click the field. 

 
 
 Windows 
 
 Using the Shift Key 

To select more than one item, hold down the Shift key while clicking the items 
you want.  Clicking on an already selected item while holding down the Shift key 
deselects the item. 

  
Using the Control Key 
Holding down the Control key while dragging the end point of a constraint will 
maintain its current length.  Control-drag will also maintain current connections 
of constraints and mass objects. 
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Keyboard Shortcuts 
Macintosh 
Key   Action 

 +   Steps forward one frame 
 -   Steps backward one frame 
 Shift-Command-R Runs from the last computed frame 
 F1 or Command-Z Undo 
 F2 or Command-X Cut 
 F3 or Command-C Copy 
 F4 or Command-V Paste 
 Space Bar  Selects the Arrow tool 
 r   Selects the Rotation tool 
 a   Selects the Anchor tool 
 z   Selects the Zoom in tool 
 Z   Selects the Zoom out tool 
  

Windows 
 Key   Action 
 +   Steps forward one frame 

-   Steps backward one frame 
 Shift-Control-R Runs from the last computed frame 
 Space bar  Selects the Arrow tool 
 r,R   Select the Rotation tool 
 a,A   Select the Anchor tool 
 z   Select the Zoom in tool 
 Z   Select the Zoom out tool 
 Alt-Enter, Ctrl-I Invokes the Object Properties window 
 Alt-Backspace  Undo 
 Delete   Clear 
 Shift-Delete  Cut 
 Control-Insert  Copy 
 Shift-Insert  Paste 
 F1   Help 
 F2   New document 
 Alt-F4   Quit 
 F5   Run/Stop 
 F12   Save As 
 Shift-F12   Save 
 Control-F12  Open 
 Control-Shift-F12 Print 
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